Synology Photos Backup Slowness

TD;LR – I had manual DNS setup (1.1.1.1 and 8.8.8.8) in my NAS. Everything is good now after I turned off manual DNS.

I have a Synology NAS for my house and have setup own backup cloud. Recently, My wife has complained to me Synology photo auto backup is extremely slow, and it is super slow for me too – it took a few minutes to upload just one picture.

So I started to check where the slow comes from. I know the NAS is not fast since it is 5 years old but it is not too slow too. I am able to transfer files to it and access it from my phone from DS File.

I searched a lot and suspected the slowness comes from not enough memory and DSM 7 is memory-hungry. As DSM 7 claimed it requires at least 1G RAM and my DS216+II has exact 1G RAM – so it could be the issue that my RAM is on the low side. And the memory usage is around 80% from Resource Monitor. After trying for almost one whole day and it went nowhere, I have ordered a 8GB DDR3L RAM online.

And today I did some more search and one person mentioned about switching off IPv6 from NAS. So I decided to login and take a look on my NAS network setup. And the first thing I saw from Network setup is manual DNS servers: 1.1.1.1 and 8.8.8.8. That strike me immediately – I quite like these two DNS but it has given me some trouble before. Last time I had slowness on connecting to my company’s Citrix. I am based in Singapore but somehow I am always redirected to US Citrix farm. It turned out I had DNS set to these two on my machine. So that probably explains – underlying Synology photos services uses DNS and the connection from Synology Photos app from my phone may all the way from Singapore to US and back to Singapore.

I have set DNS to auto on NAS and rebooted it, and now backup process is flying.

But my 8GB RAM is on the way – I guess I will just replace it anyway for good.

Leave a Reply

Your email address will not be published.